4 Replies Latest reply: Feb 21, 2011 1:18 PM by rwilliams-vocollect RSS

Cisco WLC 5508 and SNMP

I am currently evaluating Solarwinds and I am having trouble getting my WLC 5508 to respond to SNMP queries from the NPM.  I am able to query it using other SNMP tools from the same box NPM is installed on.  I am not exactly sure what is going on since I am able to query my other controllers without a problem.   Has anyone seen this issue before?

Thanks

Rob

 
  • Re: Cisco WLC 5508 and SNMP
    Andy McBride

    If you have other SNMP tools on that machine chances are the SNMP ports (161, 162) are taken by those tools. if you shut down the other tools, make sure they are not set to autostart then stop and restart start NPM services from All Programs -> SolarWinds Orion -> Advanced Features -> Orion Service Manager. If it still will not start, make sure the other tools are off, reboot and start NPM.

    Alternativly, you could do a packet capture on the NPM server and see the SNMP rrequests/responses and troubleshoot those.

  • Re: Cisco WLC 5508 and SNMP
    Andy McBride

    Also check out this thread where a community member has posted a work-around.

    Thin APs do not show on controller Cisco 5508

    • Re: Cisco WLC 5508 and SNMP

      Ok I did an snmp debug on the controller and also did a packet capture.  The packet capture reports that there is a bad checksum and the debug on the controller reveals the following:

       

      SNMPTask: Feb 21 13:51:27.794: SNMPD: Packet from: 10.4.10.1:57520, in_packet_len = 49

      *SNMPTask: Feb 21 13:51:27.794: SNMPD: calling srDoSnmp.

      *SNMPTask: Feb 21 13:51:27.794: SNMPD: received get pdu

      *SNMPTask: Feb 21 13:51:27.794: SNMPD:calling do_response

      *SNMPTask: Feb 21 13:51:27.794: Searching for requested instance of sysObjectID

      *SNMPTask: Feb 21 13:51:27.794: SNMPD: Sending SNMP packet to 10.4.10.1:57520, out_packet_len = 58

      *SNMPTask: Feb 21 13:51:30.804: SNMPD: Packet from: 10.4.10.1:57520, in_packet_len = 49

      *SNMPTask: Feb 21 13:51:30.804: SNMPD: calling srDoSnmp.

      *SNMPTask: Feb 21 13:51:30.804: SNMPD: received get pdu

      *SNMPTask: Feb 21 13:51:30.804: SNMPD:calling do_response

      *SNMPTask: Feb 21 13:51:30.804: Searching for requested instance of sysObjectID

      *SNMPTask: Feb 21 13:51:30.804: SNMPD: Sending SNMP packet to 10.4.10.1:57520, out_packet_len = 58

      Now I know I am using the correct snmp community string and I even deleted all of them and recreated via the CLI.  I do not have any acl set for this either so as of right now so I can snmpwalk from any pc on the network.  I will do some more digging to see, but not sure why this is happening.

    • Re: Cisco WLC 5508 and SNMP

      UPDATE:

      Just did an snmp query using PAESSLER PRTG and it successfully was able to query the controller via snmp.  HMMMMM