1 Reply Latest reply: Nov 17, 2011 9:55 AM by SteveSW RSS

Workspace Studio Assertation Failed error

giantbean

We use the workspace studio to keep a dashboard up and running for us to view, and it seems that daily we are seeing this error message:

After I see this error, I have to close the Workspace Studio and launch it again before it will poll again.  I am running Toolset version 10.7.0.103, have installed Hotfix 2.  Any ideas?

 
  • Re: Workspace Studio Assertation Failed error
    SteveSW

    giantbean,

    Please open a support ticket for this case so we can work with you to get this issue resolved. You will want to reference this thread and support will want to get your Workspace Studio logs.

    You can turn on logging by locating the WorkspaceStudio.exe.config file usually located in <Program Files>\SolarWinds\Toolset. Make sure the Workspace Studio is closed, then open the config file and change all of the <level value="OFF" /> to <level value="ON" />. See below for excerpt of config file:


        <root>
          <level value="ALL"/>
          <appender-ref ref="RollingLogFileAppender"/>
          <appender-ref ref="OutputDebugStringAppender"/>
          <appender-ref ref="DebugAppender"/>
        </root>
        <logger name="SolarWinds.Toolset.IEE.CommonPollingEngine.InterfacePoller">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="SolarWinds.Toolset.IEE.CommonPollingEngine.PollingEngine">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="SolarWinds.Toolset.IEE.HostApp.EntryPoint">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="SolarWinds.Toolset.IEE.Gui.DashboardForm">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="Scheduler">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="ResponseTimePollerLog">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="DeviceManager">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="SolarWinds.Toolset.IEE.ActivePoller">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="SolarWinds.Toolset.IEE.UpdateChecker">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="SysInfoPollerLog">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="TFTPServer.Instance">
          <additivity value="true" />
          <level value="OFF" />
        </logger>
        <logger name="SolarWinds.Toolset.IEE.HostApp.AppLoader">
          <additivity value="true" />
          <level value="ERROR" />
        </logger>

    Then start up the Workspace Studio and reproduce the problem. The logs can be found at:
    <ALL USERS PROFILE>Application Data\SolarWinds. Look for "...-Dashboard.log..." files.

    --HTH

    Steve