12 Replies Latest reply: Dec 12, 2012 2:25 PM by Mike Hale RSS

Storage Profiler and AX4

DirtySouth

Has anyone managed to get Storage Profiler to work with a Dell/EMC AX4?

 
  • Re: Storage Profiler and AX4
    HolyGuacamole

    Yes, it should work fine for an AX4 array. If you are facing any issues gathering information?

    • Re: Storage Profiler and AX4
      DirtySouth

      I was trying to use our EMC SMI-Provider, but it would not accept either teh AX4's IP or serial number. Is there another method for monitoring it?

      • Re: Storage Profiler and AX4
        HolyGuacamole

        SMI-S is the way to do it. If you have already followed the instructions as per page 17 of this doc  http://www.solarwinds.com/support/profiler/docs/SMISProvider.pdf (which is also in the product help) and looked at the Troubleshooting FAQ that follows, please open a support ticket (http://www.solarwinds.com/support/ticket ) and post the case id back to the forum

        • Re: Storage Profiler and AX4

          DirtySouth--

          If you do open a support ticket, please also reference this thread and post any solutions you get from Support.

          Many thanks,

          M

          • Re: Storage Profiler and AX4
            DirtySouth

            I've followed those steps. They worked fine when adding our NS-120 a year ago. When I attempt to add one of our AX4's, I get error, "HTTP Error (401 Authorization Requred)." I know for a fact that I'm using the right credentials.

            Are you certain this works if the AX is running Navisphere Express?

            • Re: Storage Profiler and AX4
              bmrad

              Yes, we have had success with the AX before, and have validated support with EMC.  The only difference is the AX does not provide performance statistics.

              Brian

            • Re: Storage Profiler and AX4
              Deltona

              Hi,

              You need to make sure that the SMI-S provider can communicate with the Storage Array.
              Run the TestSmiProvider.exe \Program Files\EMC\ECIM\ECOM\bin and connect to the AX4
              Once you connect you generate a key file which enables communication between the server running the SMI-S Provider and the Storage Array.

              In Profiler, under Resource Configuration for the Storage Array, make sure you've got the following filled out correctly under SMI-S field:

              Status: On
              CIM Namespace: /root/emc
              Username: admin
              Password:
              Provider IP address: <IP address of server with SMI-S provider installed>
              Provider HTTP Port: 5988 (Make sure this port is not blocked)
              Provider HTTPS Port: 5989 (Make sure this port is not blocked)
              Serial No: this you get after running a test
              Provider Cimom Namespace: /interop
              Provider Vendor Namespace: /root/emc
              Template: EMC Clariion

              If you are using Navisphere Express and would like to get performance statistics then you will have to enable the following in the Storage Array's web console:

              System > Services > Diagnostic Files... > Performance Logs...
              Click start to start logging performance metrics. The logging only lasts for 7 days so you will have to manually start logging again after each 7 day period.
              In order to log indefinitely, you need to upgrade Navisphere.

              HTH

              • Re: Storage Profiler and AX4
                DirtySouth

                When I run the addsys command from the TestSmiProvider.exe, I get an error saying "HTTP Error (401 Authorization Requried)". I  know for a fact the username/password I entered is correct because I can login to the AX4 using the same credentials.

                I'm not following you on where you're seeing the "SMI-S field" configuration stuff. Also, I've read through the SolarWinds documention a dozen times and I don't see anything about generating a key. Maybe I'm missing something simple here.

                • Re: Storage Profiler and AX4
                  Deltona

                  Try Using the admin account instead. Default password below:

                  Before you configure the provider, please makes sure you have the following information

                  • Controller IP Addresses
                  • Navisphere ID and Password with at least view only privileges

                  1.     Download the provider

                  ·         Requires a login to powerlink - https://powerlink.emc.com    

                  ·         Location: Home > Support > Software Downloads and Licensing > Downloads S-Z > SMI-S Provider

                  ·         Download the latest provider available. 

                  2.     Install the Provider

                  (a)   Follow the instructions included with the download to install the provider. 

                  (b)   To Login:

                                    i.    Run the TestSmiProvider.exe (located at <install_dir>\ECIM\ECOM\bin).

                                   ii.    Accept defaults for host, connection type and port.                 
                  Username :  LocalDir/admin     Password :  
                  #1Password

                  3.     Register each Array with the Provider

                  (a)   Symmetrix: Symmetrix arrays are discovered automatically by the provider. The host where the provider is installed must have at least one gatekeeper LUN presented to it from the array.

                  (b)   Clariions (locally attached): The locally attached Clariions are discovered automatically, but requires the user add authorization information for each Clariions storage processor.  For Clariions, we recommend using the out of band method.

                  (c)   Out-of-band Clariions & Symmetrix: (Note: out-of-band means no LUNs are presented to the host where the provider is running)

                                    i.    Log into the provider

                                   ii.    Run the addsys command

                                  iii.    Type 'y' at the Add System prompt

                                  iv.    Choose the Array Type to be monitored (1 for Clariion, 2 for Symmetrix)

                                   v.    If Clariion, enter the IP address of Storage Processor A and B.

                                  vi.    Type the Address type from step 5 above for both Storage Processors (2 if IP Address, 3 if Array ID)

                                 vii.    Type the Username and Password for a user with at least View Only privileges on the Array.

                                viii.    You should see a success message with the array identifier. (Ex: Clariion+APM#######) Note down this Identifier for use in Profiler. 

                  (d)   Clariion Only: Log into Navisphere, and enable Statistics Logging for both Storage Processors

                  Note:  For provider version 4.0.x and 4.1.0, the provider password expires every ninety days. 

                  -

                  With regards to the SMI-S Field, first you need to add the Storage Array then click on the spanner belonging to the resource:

                  • Re: Storage Profiler and AX4
                    DirtySouth

                    Thanks, but those are the exact same instructions i've read through numerous times. There is no default admin account configured on this AX. We have another account that is used to configure the device and that is the one I'm using.

                    I'll keep looking around and trying to figure it out.

                    • Re: Storage Profiler and AX4
                      DirtySouth

                      Well, I'm not exactly sure how, but I finally got the AX to shop up. I appreciate all the help.

                      On a side note, has anyone managed to get Profiler to work with EMC VNX? Based on the error I received, it could be a limitation of the SMI Provider.

            • Re: Storage Profiler and AX4
              Mike Hale

              This error is could be caused by failing to log into the testsmiprovider.exe app correctly.  If you mistype your password or credentials, the app doesn't warn you. The only symptom of this is trying to add devices and getting that 401 error.  Exiting the app and relogging in with the correct creds should make it work.