It has been a busy week and a half in the browser world with both IE9 and FF4 being released to the world.  Like myself, many of our customers either have already upgraded or want to upgrade their browsers to the latest and greatest, but have called us to see if we support them yet.

 

The formal answer is no, not with the shipping products today.  We plan to support them in versions later on this year depending on the product you are asking about (Orion, Profiler or Hyper9).  For Orion, we plan to add support for these two product versions in the next release of size, including dropping support for IE6.  I blogged about this a few weeks back and you can read Announcement of end of support for Internet Explorer (IE) 6 in next Orion NPM version. Also, when I say release of size, this does not mean a Service Pack or a Service Release. 

 

If you choose to brave out on your own and use these browser versions, there are a couple issues we know about.  The largest one is with Firefox 4, in which if you currently try to go to the Orion web browser from your PC, you will get the mobile view of Orion instead.  Here is a manual workaround to this.

 

On the Orion server, open <drive_installed_on>:\Inetpub\SolarWinds\bin\web_browsers_patch.xml  
Add section within Devices section:   
<!--  FireFox4 -->   
        <device user_agent="Mozilla/5.0 (rv:2.0b10) Gecko/20100101 Firefox/4.0" fall_back="firefox" id="firefox_4_0">   
            <group id="product_info">   
                <capability name="model_name" value="4.0" />   
            </group>   
        </device>

 

That’s it, any questions, please feel free to let me know.